Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2025 - 10:00 UTC
Scheduled
Our blockchain provider, cheqd, will be performing an update to their mainnet. During the update the Truvera production environment and wallet may be affected as DID and revocation updates and lookups might fail.
Posted Nov 05, 2025 - 10:01 UTC
This scheduled maintenance affected: Truvera API (API (production)), Blockchain (Cheqd Node (mainnet)), and Truvera Wallet.