Cheqd Testnet is down

Incident Report for Truvera

Resolved

Cheqd has resolved their testnet chain issue. Systems are back online.
Posted May 28, 2025 - 23:34 UTC

Investigating

Our upstream dependency on cheqd's testnet is down due to a failed upgrade on their side. They are actively working to resolve it.

During this time blockchain writes will be delayed and status checks for revocable credentials will come back as, "Unknown".
Posted May 28, 2025 - 14:10 UTC
This incident affected: Truvera API (API (sandbox)) and Blockchain (Cheqd Node (testnet)).